Googleお手製WPプラグイン、site-kitでエラー出たので対処

教えてもらったので早速入れてみた

今日会社で、Google先生がとうとうWPプラグインを出したと聞いたので入れてみました。
もしかしたら仕事で使うかもしれない…ということで備忘録代わりに記録しておきます。

手順は簡単で、下記のサイトからプラグインを入手することができます。

https://sitekit.withgoogle.com/

Get developer beta > download right here の順でダウンロード。
プラグインをWPのpluginにぶちこめばそのまま使えます。
聞いた話によれば、現在はβ版ですが正式版が出ればそのままアップデートすることも可能、らしい。
つまりとりあえず入れておけってことです。

やれることは極単純で、Search Consoleとかをこっちで軽く見れる、みたいな感じ。
ちなみに、ちゃんと設定すればAnalyticsのデータなどをWPの管理画面で確認することができます。
正直普通に進めればAnalyticsとの連携画面に簡単に行けちゃうので、その辺はなんとなくで頑張ってください。
この記事はそれを解説するアレコレじゃないです。

一瞬詰まったエラー

エラーが出たんです。
「お前なんだよそのドメイン!聞いてねえぞ!」みたいな。
他の人も書いてるかもしれないですけど、ぼくも書くよ。

具体的には手順2つ目の、認証するよ!って部分です。
メールアドレスの認証を済ませて自分のWPに戻ったら「Unknown Error」とかいうのが赤エラーでダッシュボードに出ました。

とりあえず解決方法は下記のページを見ればあります。

https://github.com/google/site-kit-wp/issues/4

原因は単純で、WP管理画面の「設定 > 一般」のサイトアドレス(URL)の2つがhttpsになってないことでした。
要は、

ぼく「この管理画面のアドレスは、https://saikofall.com~だよ!」
Google「WPの管理画面で設定されたWordPressアドレスを見るよ!」
Google「https://saikofall.com~ってなってるけど…?おかしいよ?」

っていうエラーでした。
要はsite-kitの手順1でOauthコードをhttpsで発行してるのに、手順2で参照しようとしたらなぜかhttpでGoogle先生がエラーを返したわけです。

一般設定でhttpsに直してOauthコードの発行からやり直したら無事に先へ進めました。

っていうだけのエラーでした。
10分迷いました。

それでは今日はここらでサヨウナラー

関連記事

デフォルト画像
2019.11.13
無駄に時間を費やしてコメント機能だけ取り付けました

教えてもらったので早速入れてみた 今日会社で、Google先生がとうとうWPプラグインを出したと聞いたので入れてみました。もしかしたら仕事で使うかもしれない…ということで備忘録代わりに記録しておきます。 手順は簡単で、下記のサイトからプラグインを入手することができます。 https://sitekit.withgoogle.com/ Get developer beta > download right here の順でダウンロード。プラグインをWPのpluginにぶちこめばそのまま使えます。聞いた話によれば、現在はβ版ですが正式版が出ればそのままアップデートすることも可能、らしい。つまりとりあえず入れておけってことです。 やれることは極単純で、Search Consoleとかをこっちで軽く見れる、みたいな感じ。ちなみに、ちゃんと設定すればAnalyticsのデータなどをWPの管理画面で確認することができます。正直普通に進めればAnalyticsとの連携画面に簡単に行けちゃうので、その辺はなんとなくで頑張ってください。この記事はそれを解説するアレコレじゃないです。 一瞬詰まったエラー エラーが出たんです。「お前なんだよそのドメイン!聞いてねえぞ!」みたいな。他の人も書いてるかもしれないですけど、ぼくも書くよ。 具体的には手順2つ目の、認証するよ!って部分です。メールアドレスの認証を済ませて自分のWPに戻ったら「Unknown Error」とかいうのが赤エラーでダッシュボードに出ました。 とりあえず解決方法は下記のページを見ればあります。 https://github.com/google/site-kit-wp/issues/4 原因は単純で、WP管理画面の「設定 > 一般」のサイトアドレス(URL)の2つがhttpsになってないことでした。要は、 ぼく「この管理画面のアドレスは、https://saikofall.com~だよ!」Google「WPの管理画面で設定されたWordPressアドレスを見るよ!」Google「https://saikofall.com~ってなってるけど…?おかしいよ?」 っていうエラーでした。要はsite-kitの手順1でOauthコードをhttpsで発行してるのに、手順2で参照しようとしたらなぜかhttpでGoogle先生がエラーを返したわけです。 一般設定でhttpsに直してOauthコードの発行からやり直したら無事に先へ進めました。 っていうだけのエラーでした。10分迷いました。 それでは今日はここらでサヨウナラー

デフォルト画像
2017.09.21
ZOOT NATIVEは神回線を実現させるぞ

教えてもらったので早速入れてみた 今日会社で、Google先生がとうとうWPプラグインを出したと聞いたので入れてみました。もしかしたら仕事で使うかもしれない…ということで備忘録代わりに記録しておきます。 手順は簡単で、下記のサイトからプラグインを入手することができます。 https://sitekit.withgoogle.com/ Get developer beta > download right here の順でダウンロード。プラグインをWPのpluginにぶちこめばそのまま使えます。聞いた話によれば、現在はβ版ですが正式版が出ればそのままアップデートすることも可能、らしい。つまりとりあえず入れておけってことです。 やれることは極単純で、Search Consoleとかをこっちで軽く見れる、みたいな感じ。ちなみに、ちゃんと設定すればAnalyticsのデータなどをWPの管理画面で確認することができます。正直普通に進めればAnalyticsとの連携画面に簡単に行けちゃうので、その辺はなんとなくで頑張ってください。この記事はそれを解説するアレコレじゃないです。 一瞬詰まったエラー エラーが出たんです。「お前なんだよそのドメイン!聞いてねえぞ!」みたいな。他の人も書いてるかもしれないですけど、ぼくも書くよ。 具体的には手順2つ目の、認証するよ!って部分です。メールアドレスの認証を済ませて自分のWPに戻ったら「Unknown Error」とかいうのが赤エラーでダッシュボードに出ました。 とりあえず解決方法は下記のページを見ればあります。 https://github.com/google/site-kit-wp/issues/4 原因は単純で、WP管理画面の「設定 > 一般」のサイトアドレス(URL)の2つがhttpsになってないことでした。要は、 ぼく「この管理画面のアドレスは、https://saikofall.com~だよ!」Google「WPの管理画面で設定されたWordPressアドレスを見るよ!」Google「https://saikofall.com~ってなってるけど…?おかしいよ?」 っていうエラーでした。要はsite-kitの手順1でOauthコードをhttpsで発行してるのに、手順2で参照しようとしたらなぜかhttpでGoogle先生がエラーを返したわけです。 一般設定でhttpsに直してOauthコードの発行からやり直したら無事に先へ進めました。 っていうだけのエラーでした。10分迷いました。 それでは今日はここらでサヨウナラー

デフォルト画像
2019.04.02
家でもWordPress5.X系を触ることにした

教えてもらったので早速入れてみた 今日会社で、Google先生がとうとうWPプラグインを出したと聞いたので入れてみました。もしかしたら仕事で使うかもしれない…ということで備忘録代わりに記録しておきます。 手順は簡単で、下記のサイトからプラグインを入手することができます。 https://sitekit.withgoogle.com/ Get developer beta > download right here の順でダウンロード。プラグインをWPのpluginにぶちこめばそのまま使えます。聞いた話によれば、現在はβ版ですが正式版が出ればそのままアップデートすることも可能、らしい。つまりとりあえず入れておけってことです。 やれることは極単純で、Search Consoleとかをこっちで軽く見れる、みたいな感じ。ちなみに、ちゃんと設定すればAnalyticsのデータなどをWPの管理画面で確認することができます。正直普通に進めればAnalyticsとの連携画面に簡単に行けちゃうので、その辺はなんとなくで頑張ってください。この記事はそれを解説するアレコレじゃないです。 一瞬詰まったエラー エラーが出たんです。「お前なんだよそのドメイン!聞いてねえぞ!」みたいな。他の人も書いてるかもしれないですけど、ぼくも書くよ。 具体的には手順2つ目の、認証するよ!って部分です。メールアドレスの認証を済ませて自分のWPに戻ったら「Unknown Error」とかいうのが赤エラーでダッシュボードに出ました。 とりあえず解決方法は下記のページを見ればあります。 https://github.com/google/site-kit-wp/issues/4 原因は単純で、WP管理画面の「設定 > 一般」のサイトアドレス(URL)の2つがhttpsになってないことでした。要は、 ぼく「この管理画面のアドレスは、https://saikofall.com~だよ!」Google「WPの管理画面で設定されたWordPressアドレスを見るよ!」Google「https://saikofall.com~ってなってるけど…?おかしいよ?」 っていうエラーでした。要はsite-kitの手順1でOauthコードをhttpsで発行してるのに、手順2で参照しようとしたらなぜかhttpでGoogle先生がエラーを返したわけです。 一般設定でhttpsに直してOauthコードの発行からやり直したら無事に先へ進めました。 っていうだけのエラーでした。10分迷いました。 それでは今日はここらでサヨウナラー